在树莓派上安装tensorflow

树莓派3b+、树莓派4

tensorflow==1.8

是因为找到的代码版本是1.7的,很老旧了。如果使用pip默认安装的版本太新。所以就找了一个最接近的。

折腾了好久,其实树莓派的pip源是一个单独的源,和一般的linux下的pip的源不是同一个。嗯,真的是折腾了好久才ok。

树莓派pip源网站

tensorflow树莓派源

我装的是python2.7版本的

tensorflow-1.8.0-cp27-none-linux_armv7l.whl

tensorflow-1.8.0-cp27-none-linux_armv6l.whl

建议两个都下载,都试一试,因为有些时候会报错为平台不支持。通常安装不是特定为树莓派定制的程序时都会这样。

一开始我是想装conda环境,然后在里面安装tensorflow的,结果conda装不上,miniconda也装不上,报错都是平台不支持。32位64位的安装包都不行。然后我在树莓派4上安装了64位,但是依旧无法安装conda。

又想的装个docker,折腾了一顿docker,但是拉镜像启动总是出问题,遂作罢。从tensorflow官网上看树莓派安装指南,让我交叉编译,但是交叉编译的时候也会报错,好像是一个弹出交互窗口需要选择的错误。奈何我docker不熟,遂作罢。 继续辗转多次,于是用上面的安装包解决了。

下载好后运行

pip install tensorflow-1.8.0-cp27-none-linux_armv7l.whl

具体根据你的包名来决定是6还是7

网络好的话一般就装好了,如果报错那就复制一下请求的地址,手动在浏览器中把需要依赖的包安装。命令类似

pip install 包名

还有一种错误是包的哈希值和不吻合,谷歌的答案是需要更新pip,这也可以。但是pip会把tensorflow的版本提升到1.14。当然你也可以继续安装1.8,电脑会卸载1.14,安装1.8. 这里我还是推荐下载哈希值不吻合的包,单独安装,然后重新执行tensorflow的安装命令。

最后贴一个我要运行的代码文件,是github上一个识别项目。好处在于只要替换掉需要训练图片的文件就可以训练出来模型,然后就可以执行了。可以快速上手使用,吐槽一下现在各种教程都是用现成的图片库训练,如何训练个新的图片类型统统不讲,我不想懂原理,我就想上来就用。会就是会,不会就是不会,抄的就是抄的,装啥装啊!

tensorflow1.7图像识别